1

Closed

Compilation error when upgraded to latest version

description

Hi,

I have updated to 0.9.8. It is throwing an error in CompileChunk and many other places.
LuaChunk LogicCode = LuaEngine.CompileChunk(Logic, Code, true)
The comments are also written in german so i am not able to understand what is expected in those additional variables. Documentation doesn't seem updated. Kindly help
Closed Jan 17, 2015 at 10:04 PM by NeoLithos

comments

anchatterjee wrote Nov 9, 2014 at 12:46 PM

The upgrade attempted is from 0.8.10 to latest

NeoLithos wrote Nov 10, 2014 at 9:17 AM

Hi,

I am currently working on an update of the documentation. But this is always the hardes part.

I change the debug-Flag to an interface, to support more then one debug engine. It is now possible to implement your own debugger.

To the argument:
old value -> new value
false -> null
true -> Lua.DefaultDebugEngine // this is the stacktrace debugger
Or your use NeoLua.Dbg an inherit from LuaTraceLineDebugger.

Sry, for the german comments, but sometime I does not notices which language I am writing in :).

wrote Jan 17, 2015 at 10:04 PM